読者です 読者をやめる 読者になる 読者になる

Redmine0.9.0にアップデート

困ったところ。

db:migrate でエラー

rack 1.0.1 がなかったため。(最新版じゃだめ)

db:migrate_plugins でエラー

rake db:migrate:upgrade_plugin_migrations
プラグインスキーマ?を移行する必要あり。

テストがこける - その1

  • thoughtbot-shoulda
  • nofxx-object_daddy

がない。

gem install thoughtbot-shoulda --source=http://gems.github.com
gem install nofxx-object_daddy --source=http://gems.github.com

テストがこける - その2

redmine0.9.0 では fixture なくなっちゃった?
さて、ここから何に移行すべきか?
redmine0.9.0 では object_daddy を使っているけれど、

http://wota.jp/ac/?date=20091222

からみると、あんまり良くなさそう。